Monday, August 13, 2012

Dyno and a disappointment!

Well, a few weeks back we had a group Dyno day - never did that before, so I figured why not check it out!?  My brother and I drove a few hours to San Francisco and the guys at Dito's Motors were great!  Two days of dyno tuning for our group - probably 15 guys with their AMG power.

Jerry came in from Texas ( http://www.eurocharged.com/) to do the dyno tuning - and MANY guys had a blast and some big power was put down.  It was a usual Bay Area day - about 58 degrees outside, of course my brother and I forgot that it was colder there so it was quite chilly in our shorts and T-shirts (LOL).

I had my first run around 11:15am - got on the dyno and did a baseline...  



A whole whopping 400HP at the wheels... which isn't all that bad, but in perspective to other cars but we knew something was up...  my secondary water pump was failing so it couldn't cool the intake charge, my IATs were 170-180F so the computer was dumping all the fuel possible into the cylinders which pretty much made my AFR's dive into the low 10's (most likely into the 9s and even 8s)...  so we had to pack up and get a new pump installed...  The guys were great at the shop, a few guys even offered to replace the pump that day and get things dialed back in- but I let it up to the warranty to fix things (hey, that's why you buy one!) :-)

Oh well, next time I run into a Dyno - things should be much better!  I got a new toy to start logging my ECU to make sure stuff like this doesn't happen in the future... next blog!

Fatwallet

FatWallet Coupons and Deals